This website uses cookies for visitor traffic analysis. By using the website, you agree with storing the cookies on your computer.More information

Eclipse Photon with ANT and JRE6

Post to Twitter

The support for ANT and JRE6 with Eclipse Photon.

The plugin was created for:

Version: Photon Release (4.8.0)
Build id: 20180619-1200

Don't forget the -clean start (read the original article for more details)!

One more thing you should do:

Photon includes ANT > 1.10. This version requires Java 8. In order to use Java 6, you have to download ANT 1.9.x. Simply download ANT and set the ANT Home to your version, via

(Window >>) Preferences >> ANT >> Runtime >> Ant Home...

If you try to use the bundled ANT with JRE 6, it will fail with an Exception.

Download the plugin from here. It works for us - no warranty!

More Details: Eclipse Oxygen.2 with ANT and JRE6.

2 Responses to “Eclipse Photon with ANT and JRE6”

  1. Lee says:

    Hello.

    My Eclipse Photon version is as follow.
    Version: 2018-09 (4.9.0)
    Build id: 20180917-1800

    and Ant plug-in versions are as follows.
    1) org.eclipse.ant.core_3.5.200.v20180822-0553.jar
    2) org.eclipse.ant.launching_1.2.200.v20180822-0553.jar
    3) org.eclipse.ant.ui_3.7.200.v20180822-0553.jar

    I deleted the above jar files, and I copied your patched jar files to eclipse plugin directory.

    There was no problem in use yet.

    Can I do it like this?

    Thank you.

  2. rjahn says:

    Sure, everything is fine if its working :-)

Leave a Reply

Spam protection by WP Captcha-Free