This website uses cookies for visitor traffic analysis. By using the website, you agree with storing the cookies on your computer.More information

BeagleBoard xm and WLAN

I tried to connect an USB WLAN adapter to my board and thought it should work out-of-the-box like my cordless mouse (WLAN c'mon). But that was not the case. The good news is that it already works. The bad news is that it took hours to figure out how it works.

Maybe my requirements are too specific (I don't think so), but the documentation in the Internet about beagleboard stuff is not really good. I found a lot of old articles and most of them did not work or did not work with my software. It took hours to find information snippets for my requirements.
Are a fixed MAC address and WLAN support really too modern?

Anyway, I try to prepare my hardware before I start with development. I'm not totally happy at the moment because my touch screen does not work with JavaFX applications. It's an ELO touchscreen EL1725 connected via USB. I hope that this ticket solves my problem.

Some background information for my WLAN adapter

I read the manual before I bought an adapter and was suprised that only some specific adapters were supported (maybe the documentation is not up-to-date). I chose Trendnet TEW-648UBM Micro. It was not in the list, but I thought it could work...

After I plugged the adapter to my last free USB port I checked dmesg and saw no errors. The adapter was detected and I thought it should work. Typed

ifup wlan0

and got error messages. Checked dmesg and saw an information about missing firmware.

The adapter needs a firmware but it didn't find it on my SD card :( . I asked one of my best friends, google, and got a lot of results but no answer. So I tried

opkg list|grep realtek

because dmesg showed me that my adapter has a realtek chip. I got results, but no firmware. The next try was:

opkg list|grep firmware

I got too many results :) My next attempt:

opkg list|grep 8192cu

I found my firmware and installed it:

opkg install linux-firmware-rtl8192cu

Now the adapter was integrated but it was not configured. My WLAN is secured with a passphrase.
I tried to configure the wlan0 interface via /etc/network/interfaces and /etc/wpa_supplicant.conf but without success. So I asked google again and found some "useful" articles:

Beaglebone WiFi
Beagleboard WiFi USB dongle

The second article was not bad but did not work. The last one was better but it did not work as described :)
Mabe I did not understand something that was written between the lines.

What I did:

opkg install connman-tests connman-tools

I did nothing with /etc/network/interfaces because the connman has its own configuration! So I created a file with the name /var/lib/connman/wifi.config. To find out the SSID the following command was useful:

/usr/lib/connman/test/test-connman services

Set [WiFi] Enabled = true in /var/lib/connman/settings.

My wifi.config

Name = NetworkName
Description = Home WLAN

Type = wifi
ssid = 123456789
Passphrase = mypassword

Be sure that your Name is equal to the name in the service section. The ssid was taken from output of

/usr/lib/connman/test/test-connman services

mynetwork {wifi_<macaddr>_<sid>_managed_psk}

My /etc/network/interfaces

# The loopback interface
auto lo
iface lo inet loopback

# Wireless interfaces
#iface wlan0 inet dhcp
#       wireless_mode managed
#       wireless_essid any
#       wpa-driver wext
#       wpa-conf /etc/wpa_supplicant.conf

iface atml0 inet dhcp

# Wired or wireless interfaces
auto eth0
iface eth0 inet dhcp
iface eth1 inet dhcp

After rebooting the board the connection was established automatically. If you have problems, use gnome to check your network settings or try to establish a connection with your network.

Sometimes during startup it was not possible to load the firmware for the adapter, but normally it worked without problems. If you have problems, simply use dmesg and journalctl to find error details.

8 Responses to “BeagleBoard xm and WLAN”

  1. TDC says:

    Greetings! I've been battling this same wifi issue (with the same dongle) for a while on my XM. If I may ask, which kernel are you on? I've basically followed the same strings you have and keep running into issues. Most notably being on 3.2.28 seems to have an issue with WEP and WPA authentication (ie, if I turn off encryption on my router everything works fine). I followed your instructions perfectly and met with the same result. I can connect to the router, but authentication fails. Just trying to see what IS different about our setups.

  2. rjahn says:

    My kernel version is 3.2.28. Did you try to connect via gnome? There is a small network icon beside the clock.

    My router is secured with WPA and authentication works for me. I hope we'll find the problem :)

  3. TDC says:

    Thanks for the response. Are you using a prebuilt image (if so, can you point me to the one you used)?

  4. rjahn says:

    I built my own image from scratch as described here. I'll try to share my image tomorrow if you want?

  5. TDC says:

    Nope. You've been more than helpful. I'll follow your posts and see where I end up. Thanks again.

  6. TDC says:

    Ok, I'm back. And after a few days of battling bitbake recipes I'm more than happy to accept your very gracious offer of a pre-built image. I can't seem to get around this webkit-gtk error I get during the build.

    At your convenience, of course.

  7. rjahn says:

    Hm... I had no problems with webkit-gtk?

    Please download this archive. It contains MLO, u-boot.img, systemd-GNOME-image, modules. The archive contains fresh files without any of my configurations, but includes the mac address patch.

  8. TDC says:

    Sir, I thank you. Wifi is working perfectly.

Leave a Reply

Spam protection by WP Captcha-Free